Re: [layerindex-web][PATCH 00/15] Upgrade to Django 3.2.5 LTS and Celery 5


Richard Purdie
 

On Sun, 2021-07-18 at 16:07 -0700, Tim Orling wrote:
The current code base uses Django 2.2.x which will go out of extended
support in April 2022, but also holds us back from updating a number of
dependencies.

Update to the current Django 3.2.5 LTS and also the latest Celery 5.1.2.
Celery 4 has not had any commits since 2020 and is unlikely to be
getting much more attention from the developers.

While we are at it, upgrade all of our dependencies to the latest
versions.
I don't have the skills to review this in detail but it sounds like a
good step forward for many different reasons, thanks!

Cheers,

Richard

Join yocto@lists.yoctoproject.org to automatically receive all group messages.