Trying to get Kivy running on imx8 platform #yocto #linux #imx8

William Huang

Hi community!
I would like to get Kivy recipe going for this project as I think it would be great to add an extra GUI framework to the project; however, I'm running into an issue that I've been stuck on for a couple days now. 
I initially got it running on a rockchip (but it keeps falling back on LLVM pipe for some reason), and would like to do the same on an imx8mp platform. Unfortunately, I get a segmentation fault when getting Kivy to run on the imx8 and I couldn't find any help with Kivy's support group. I was hoping the community can lend me an extra hand/give me an extra set of eyes as I'm currently stumped.

Things I have tried so far:
o.      played around Kivy's USE_X11 & USE_WAYLAND switches
o.      Originally it was using Python 3.8.10. The Kivy I got going on rockchip was on Python 3.8.2, so I downgraded to that version.
o.      Tried using different weston versions (weston_9.0.0.imx and weston_8.0.0.imx)
o.      The stacktrace mentioned missing pthread_mutex_lock file.. thought it was pthreads related so I added glibc and libgcc to the image install
o.      Some googling showed that others use KIVY_GL_BACKEND=gl, but this did not work.

I've attached the recipe I've written up so far and related patch files. (Kivy's current doesn't seem to look for GLESv2 libraries for non-android/ios/rpi platforms), a recipe that installs Kivy examples, and attached my stacktrace for extra information.

Any help would be very much appreciated!
William Huang

PS: It's my first time posting to a mailing list. Is it proper to send source code as attachments or just copy and paste into message body? Anyways, I've attached the files for now.

Join to automatically receive all group messages.