Re: #yocto Preferred development workflow #yocto
We have many recipes appended to IMAGE_INSTALL in our image recipes and it works just fine. From your description, it sounds like you could go either way. I personally prefer to keep my image recipes as clean as possible, so I push as much as I can to individual recipes. This helps with debugging later on as your project (inevitably) gets more complex. Also... Experience has shown that the following form is a lot more readable: IMAGE_INSTALL = "recipe_1" IMAGE_INSTALL += "recipe_2" IMAGE_INSTALL += "recipe_3" IMAGE_INSTALL += "recipe_4" IMAGE_INSTALL += "recipe_5" Than this: IMAGE_INSTALL = "\ recipe_1 \ recipe_2 \ recipe_3 \ recipe_4 \ recipe_5" When your repository grows large, a recursive grep for recipe_2 will make a lot more sense if "IMAGE_INSTALL += "recipe_2"" is returned instead of "recipe_2 \". The latter form gives no clue as to how recipe_2 is being referenced. ..Ch:W.. sorry about that, right now the config files are placed in the files directory of the recipe which builds the module. -- "Perfection must be reached by degrees; she requires the slow hand of time." - Voltaire |
|