Re: build error after recent pull

Jim Abernathy

On 03/19/2012 04:25 PM, Gary Thomas wrote:
On 2012-03-19 13:25, jfabernathy wrote:
On 03/19/2012 03:13 PM, Gary Thomas wrote:
On 2012-03-19 13:04, jfabernathy wrote:
On 03/19/2012 03:03 PM, Gary Thomas wrote:
On 2012-03-19 12:59, jfabernathy wrote:
On 03/19/2012 02:55 PM, Gary Thomas wrote:
On 2012-03-19 10:02, jfabernathy wrote:
Just did a git pull today on poky and meta-intel. I tried to rebuild meta-sugarbay again and got a build error. Not sure why yet. Not critical, just a spot check of things.

NOTE: package mesa-dri-2_7.11-r13.1: task do_configure: Succeeded
NOTE: Running task 1723 of 5148 (ID: 1928, /home/jim/poky/meta/recipes-graphics/mesa/, do_compile)
NOTE: package mesa-dri-2_7.11-r13.1: task do_compile: Started
ERROR: Function failed: do_compile (see /build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/temp/log.do_compile.25687 for further information)
ERROR: Logfile of failure stored in: /build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/temp/log.do_compile.25687
Log data follows:
| DEBUG: SITE files ['endian-little', 'common-linux', 'common-glibc', 'bit-64', 'x86_64-linux', 'common']
| ERROR: Function failed: do_compile (see /build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/temp/log.do_compile.25687 for further information)
| NOTE: make -j 8
| make[1]: Entering directory `/build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/Mesa-7.11/src'
| Making sources for autoconf
| make[2]: Entering directory `/build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/Mesa-7.11/src/mapi/glapi'
| make[2]: *** No rule to make target `/build/sugarbay-master/tmp/sysroots/x86_64-linux/usr/lib/x86_64-poky-linux/gcc/x86_64-poky-linux/4.6.3/include/stddef.h', needed by
`glapi_dispatch.o'. Stop.
| make[2]: Leaving directory `/build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/Mesa-7.11/src/mapi/glapi'
| make[1]: *** [subdirs] Error 1
| make[1]: Leaving directory `/build/sugarbay-master/tmp/work/x86_64-poky-linux/mesa-dri-2_7.11-r13.1/Mesa-7.11/src'
| make: *** [default] Error 1
| ERROR: oe_runmake failed
NOTE: package mesa-dri-2_7.11-r13.1: task do_compile: Failed
ERROR: Task 1928 (/home/jim/poky/meta/recipes-graphics/mesa/, do_compile) failed with exit code '1'
What's your build host?

Was this build from scratch? There was a discussion of much the
same error on the meta-ti list last week where the host GCC was
updated between two subsequent builds that gave this error.
Building on latest release Ubuntu 11.10 (Linux ubuntu-x64 3.0.0-16-generic #29-Ubuntu SMP)

gcc is 4.6.1
Was your build from scratch? Do you use [extant] sstate cache?
I had a preview successful build and just reran that after bitbake -c cleanall core-image-sato
Do you have rm_work in your local.conf?
No to question on rm_work in local.conf

Try this:
% bitbake -c cleansstate mesa-dri
% bitbake mesa-dri
This work without errors. I'm now doing bitbake core-image-sato to see if it completes.

BTW, 'bitbake -c cleanall core-image-sato' doesn't really do much - images don't have much (any?)
stuff that needs to get cleaned. You can run 'bitbake core-image-sato' as many times as you like
and it will completely rebuild the image every time.

So if I do a git pull and want to retest with new stuff, just bitbake core-image-sato or should I do something with cleansstate??
If you run just 'bitbake core-image-sato', any packages (recipes)
which have been changed that are used by the image will be rebuilt.
You should not have to clean anything for this to work properly.
After I fixed mesa-dri and started bitbake core-image-sato, it ran for a long time and had a build failure similar to the first one on kexec-tools. I did the bitbake -c cleansstate kexec-tools trick again and restarted bitbake core-image-sato. Not sure why this is, but it seems to work.

Jim a

Join to automatically receive all group messages.