#linux #dunfell How to use eclipse with autotools without yocto plugin #linux #dunfell

Sebastian Holzgreve


we were currently upgrading our yocto system to v3.1. In the older yocto system there was the "Yocto Eclipse Plugin" available. I saw in the changelog that unfortunately that this plugin is not maintained anymore and removed.

From the past we got whole bunch of autotools based projects. Is it somehow posible to use eclipse for development and debugging keeping the projects in the autotools world?

I tried using the eSDK (Following: https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#sdk-working-projects)

Rebuilding the project from eclipse is now possible. It still complains that is can run the executable but I can start debugging. I tried to setup the debugger configuration like it was set up, when the "Yocto Eclipse Plugin" generated it. But when I try to debug the code, eclipse opens up the "Debug Perspective", also attaches to the remotly running gdbserver, but it never stops on breakpoints that were set in the eclipse GUI.

Is there any chance to use eclipse without the plugin, without converting all the packages to CMake or plain makefile projects?

Any hints or pointings to the right direction is appreciated.

Join {yocto@lists.yoctoproject.org to automatically receive all group messages.