Re: [OE-core] Hardknott (GCC10) Compiler Issues


Zoran
 

At least seems that GCC 10.2 is not the cause of the problem for my
cannelloni recipe issue:

https://github.com/mguentner/cannelloni/issues/35

The same error repeats itself with GCC 11.2 (in hardknott).

The issue is most probably optimizing GCC switches and Include paths
in further cannelloni commits (after release 1.0.0, which compiles
with both 10.2 and 11.1 fine).

Best Regards,
Zee
_______

On Mon, Jun 28, 2021 at 2:49 PM Richard Purdie
<richard.purdie@...> wrote:

On Thu, 2021-06-24 at 21:48 -0700, Chuck Wolber wrote:
All,

Please accept my apologies in advance for the detailed submission. I think
it is warranted in this case.

There is something... "odd" about the GCC 10 compiler that is delivered with
Hardknott. I am still chasing it down, so I am not yet ready to declare a
root cause or submit a bug, but I am posting what I have now in case anyone
has some insights to offer.
The issue you describe does sound strange. I was a little unclear about exactly
which combinations were passing/failing. Are you saying that some versions of
buildtools let the system work but some do not? We now have gcc 11 in master
so it would be interesting to know how things worked there and if any
regression was fixed.

I have also heard reports of issues with bison segfaulting from other sources
but I don't have anything I can point to specifically about it.

The target system should be independent of buildtools version and the target
system should also be binary reproducible so if that were changing through
changing buildtools tarball, that would be worrying in itself.

P.P.S. For the sake of completeness, I had to add the following files to the buildtools-extended
sysroot to fully complete the build of our images:

/usr/include/magic.h -> util-linux "more" command requires this.
/usr/include/zstd.h -> I do not recall which recipe required this.
/usr/bin/free -> The OpenJDK 8 build scripts need this.
/usr/include/sys/* -> openjdk-8-native
/lib/libcap.so.2 -> The binutils "dir" command quietly breaks the build without this. I am not a fan of the
lack of error checking in the binutils build...
/usr/include/sensors/error.h and sensors.h -> mesa-native
/usr/include/zstd_errors.h -> qemu-system-native
It is great to have this list, outside the non-jdk issues are probably issues we
should look at fixing in OE-Core. Do you mean binutils above for the dir command?

Cheers,



Join yocto@lists.yoctoproject.org to automatically receive all group messages.