Re: vlc 3.0.11 package issue


Khem Raj
 

On Mon, May 17, 2021 at 10:57 PM sateesh m <sateesh0457@...> wrote:

Hi ,

I am trying to run vlc-3.0.11 media player on my riscv target board. I am facing problem this package

[cli] lua interface error: Error loading script /usr/lib/vlc/lua/intf/cli.luac: ../../vlc-3.0.11.1/share/lua/modules/common.lua:3: attempt to call a nil value (global 'module')

lua package also I installed version is 5.3.6 .
usually it means lua version mismatch. You might be hitting same issue
as reported here

https://trac.videolan.org/vlc/ticket/25036

there is a patch attached to that ticket. Please try to apply that and
see if it helps.

https://trac.videolan.org/vlc/attachment/ticket/25036/0001-lua-Make-scripts-compatible-to-lua-5.4.patch

How can I fix this issue. Is I need to apply patch for this?if patch is present please give me guidance. Can anybody knows this problem help me.

Thanking you in advance.
--
Regards,
Sateesh

Join yocto@lists.yoctoproject.org to automatically receive all group messages.