BitBake recipe cache - tasks remain available after removing inheritance #yocto #bitbake

Jindra Sindelar

Hello all,

I'm starting with the Yocto project (Zeus) and I made some experiments with the kernel recipe. For one of my assignments, I needed a do_kernel_configme task, but it wasn't provided by our kernel recipe (i.e. not listed in the available tasks). I searched the available layers and found that this task is defined in poky/meta/classes/kernel-yocto.bbclass. Out of fun, I tried to inherit from that class in our kernel recipe and after parsing the recipe again, the do_kernel_configme task was available.
Later I decided to revert all my changes and removed the inheritance of kernel-yocto.bbclass. What surprises me is that the do_kernel_configme task remains available in the kernel recipe and I can still successfully run that task. I also tried to remove the content of build/tmp/cache, which, if I understand correctly, is the cache for parsing recipes. After running BitBake again, I could see the recipe was parsed from scratch. But even after that, the do_kernel_configme task still remains available for the kernel recipe.
Could anyone explain this behavior? What am I missing here?
Thank you in advance

Join to automatically receive all group messages.