Re: core-image-sato -staticdev issue


sateesh m
 

Hi Guys,

I am facing one more issue No eligible RPROVIDERs exist for 'core-image-sato'

Thanks & Regards,
Sateesh


On Sun, Apr 25, 2021 at 10:00 PM sateesh m via lists.yoctoproject.org <sateesh0457=gmail.com@...> wrote:
Hi Guys,

                I am newly facing this when I want to build core-image-sato image. how can I fix this issue can anybody know please suggest me.

local.conf I enabled EXTRA_IMAGE_FEATURES +=  "staticdev-pkgs"  but same issue I am facing.

Loading cache: 100% |                                                                                                                                        
Loaded 0 entries from dependency cache.
Parsing recipes: 100% |#######################################################################################################################################| Time: 0:00:17
Parsing of 3450 .bb files complete (0 cached, 3450 parsed). 5058 targets, 469 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES '-staticdev' (sources/openembedded-core/meta/recipes-sato/images/core-image-sato.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target '-staticdev' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['-staticdev']
ERROR: Required build target 'core-image-sato' has no buildable providers.
Missing or unbuildable dependency chain was: ['core-image-sato', '-staticdev']
 
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.
 
--
Regards,
Sateesh



--
Regards,
Sateesh

Join yocto@lists.yoctoproject.org to automatically receive all group messages.