Re: How can I use old Package version with latest Yocto version. #cups #zeus


Khem Raj
 

On 3/30/21 12:42 AM, rohitbjadhav1@gmail.com wrote:
Hi
   I was using very old version of Yocto i.e. Krogoth. In that version I am able to use following packages with respective version:
    Package name   Version
   Cups                     2.2.4
   Cups-filter            1.14.0
   qpdf                      6.0.0
   Opencv                 2.4
It was working fine. But When I switch to any other version of Yocto like  Zeus [which I have tried on ].
Specifically for cups-filter pakage observed following errors while compilation and generation of rootfs
ERROR: cups-filters-1.14.0-r0 do_compile: oe_runmake failed
ERROR: cups-filters-1.14.0-r0 do_compile: Execution of '/home/tel/imx_yocto_bsp_Zeus/Yocto_setup/build_imx6ull/tmp/work/cortexa7t2hf-neon-poky-linux-gnueabi/cups-filters/1.14.0-r0/temp/run.do_compile.17590' failed with exit code 1:
It is observed due to wrong c standard while compilation as some log says as follow:
warning: ISO C99 doesn't support unnamed structs/unions [-Wpedantic]
warning: ' LPT #' directive output may be truncated writing 6 bytes into a region of size between 1 and 1024 [-Wformat-truncation=]
warning: 'strncpy' specified bound 1024 equals destination size [-Wstringop-truncation]
filter/pdftoopvp/oprs/OPVPSplash.h:53:3: error: 'GBool' does not name a type
it seems you are locking above said packages to revisions you want, but they also have additional dependencies, eg. the one which is causing issue here is poppler, since poppler version in zeus is 0.80.0 and krogoth has 0.41, however poppler switched to using standard types for bool starting 0.71,

my suggestion is to use the versions that come with zeus release and forward port your app to consume them or second option is to fork versions then you must look at what would be the right set of packages you need to lock to older versions in-order for you to keep things going forward.

Just Need some guideline to resolve this issue.
Please also suggest is there any way to use old pakage of Yocto version to latest Yocto version.
Thanks and Regards
Rohit

Join yocto@lists.yoctoproject.org to automatically receive all group messages.