Re: debug symbols and INHIBIT_PACKAGE_STRIP = "1"


Khem Raj
 

check the build logs for the binary, see if there is some sort of symbol stripping happening. Perhaps its using install -s ?

On 3/12/21 3:17 AM, AFraser wrote:
Hi,
I'm using bitbake to build an application and I'd like to troubleshoot some segfaults that are taking place. I've set up gdbserver on a virtual machine running the application and can connect. My problem is that I cannot seem to get the image to build my binaries without stripping the symbol table.
Whenever I run:
|objdump -t _binary_|
it shows 'no symbols' under 'SYMBOL TABLE'.
So far I've added the following to build/conf/local.conf
|EXTRA_IMAGE_FEATURES = "debug-tweaks dbg-pkgs tools-sdk tools-debug "|
|INHIBIT_PACKAGE_STRIP = "1"|
|INHIBIT_PACKAGE_DEBUG_SPLIT= "1"|
I also tried adding the following to bitbake.conf:
|export CFLAGS = "${TARGET_CFLAGS} -g"|
|export LDFLAGS = "${TARGET_LDFLAGS} -g"|
Strangely, the size of the binary I'm looking at has increased. Since making these changes and the new build took much longer to run.
Running |bitbake -e _recipe_ | shows the environment of my recipe and reflects the changes made in local.conf.
Is there a way I can look at the exact gcc command that is being run to make sure it's not still being stripped somewhere? I can't seem to see it in the logs

Join yocto@lists.yoctoproject.org to automatically receive all group messages.