Re: Trouble booting basic x86 image

Paul D. DeRocco

From: Mittal, Anuj [mailto:anuj.mittal@...]

It looks like you are using the live option in hddimg image? Can you
try adding "rootwait" to kernel parameters and see if that works?

Not sure why it's not dropping to shell, but may be try
adding explicit
call to /bin/sh in meta/recipes-core/initrdscripts/files/
before this point to make sure the media is actually mounted at that

Also, have you tried wic image to see if that works?
Thanks for the advice. I decided to try wic, since that's actually the x86
default if you don't set IMAGE_FSTYPES. It also looks cleaner than hddimg,
since it has a real ext4 partition and no loop mounting.

For the 32-bit build, it produced something my BIOS wouldn't recognize as
bootable, even though it looked fine in gparted. For the 64-bit build, it
booted part way, crashing on an illegal instruction in systemd. For the
64x32-build, it booted but failed trying to run /sbin/init with error -8
(invalid executable). When I look at the drive in Ubuntu, the properties on
that file say it's a link to /lib/systemd/systemd, which makes sense.
Strangely, though, it describes it as a shared library. objdump -f says:

/media/pauld/platform/sbin/init: file format elf32-x86-64
architecture: i386:x64-32, flags 0x00000150:
start address 0x00024490

So still no joy. I'd rather get this wic version working than go back to the
hddimg version, but I'm not sure what to try next.

Ultimately, I'm just trying to get a vanilla reference build, so that when
the "real" system I'm creating doesn't work (which is often), I can compare
kernel configs, etc., to a known working system.


Ciao, Paul D. DeRocco
Paul mailto:pderocco@...

Join to automatically receive all group messages.