Trouble booting basic x86 image


Paul D. DeRocco
 

Yocto Gatesgarth, using meta-intel to build core-image-minimal
Intel D2700MUD mini-ITX mobo with D2700 Atom
Ordinary USB 2.0 flash drive

I followed the instructions in the meta-intel README, and had no problems
building the intel-core2-32 and intel-corei7-64 machines, as well as the
latter with an x32 tune. But whenever I try to boot any of them, I get the
following stuff from the kernel:

usb 1-6: new high-speed USB device number 4 using ehci-pci
usb-storage 1-6:1.0: USB Mass Storage device detected
usb-storage 1-6:1.0: Quirks match for vid 090c pid 1000: 400
scsi host4: usb-storage 1-6:1.0
scsi 4:0:0:0: Direct-Access FLASH Drive SM_USB20 1100 PQ: 0 ANSI: 4
sd 4:0:0:0: Attached scsi generic sg0 type 0
sd 4:0:0:0: [sda] 3932160 512-byte logical blocks: (2.01 GB/1.88 GiB)
sd 4:0:0:0: [sda] Write Protect is off
sd 4:0:0:0: [sda] No Caching mode page found
sd 4:0:0:0: [sda] Assume drive cache: write through
sda:
sd 4:0:0:0: [sda] Attached SCSI removable disk
(countdown from 27 to 0)
Mounted filesystems
Available block devices
major minor #blocks name
1 0 4096 ram0
... (others edited out)
1 15 4096 ram15
8 0 1966080 sda
Cannot find rootfs.img file in /run/media/* , dropping to a shell

At this point, it doesn't drop to a shell, but just sits there, responding
to keys by echoing them, so I have no way of investigating. Ctrl-Alt-Del
reboots.

Since there is no kernel serial output on this board, even though the kernel
command requests it, I videoed the startup, but didn't anything that looked
suspicious. I didn't see any message, though, about mounting anything in
/run/media.

As I've said, I've tried three different builds, totally generic except for
using the Intel BSP layer. I've tried two different USB drives. I've tried
it with EFI enabled and disabled in the BIOS. I've looked at the drive on
the PC, and the contents look normal. So why can't it find the rootfs.img
file, which is right there on sda, large as life? Anyone have any ideas what
I could be doing wrong?

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com

Join yocto@lists.yoctoproject.org to automatically receive all group messages.