[meta-gplv2] [PATCH] disable-gplv3.inc: Update pattern match to what we really mean


Richard Purdie
 

This code wants to disable GPLv3 and GPLv3+ however the pattern
didnt specify that and with recent changes in OE-Core, it needs
to be specific. Update the pattern to be specific.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
conf/distro/include/disable-gplv3.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/conf/distro/include/disable-gplv3.inc b/conf/distro/include/disable-gplv3.inc
index 761be7d..bded378 100644
--- a/conf/distro/include/disable-gplv3.inc
+++ b/conf/distro/include/disable-gplv3.inc
@@ -1,3 +1,3 @@
-INCOMPATIBLE_LICENSE = '*GPLv3'
+INCOMPATIBLE_LICENSE = '*GPLv3*'
WARN_QA_remove = 'incompatible-license'
RDEPENDS_${PN}-ptest_remove_pn-glib-2.0 = "python3-dbusmock"
--
2.27.0

Join yocto@lists.yoctoproject.org to automatically receive all group messages.