What to do when a patch isn't needed?


Paul D. DeRocco
 

I'm upgrading a project from Pyro to Gatesgarth. Building the toolchain, it
barfs on a patch which isn't needed. Here's one of the error messages:

ERROR: binutils-native-2.35-r0 do_patch: Command Error: 'quilt --quiltrc
/home/pauld/yocto-gatesgarth/build-intel32/tmp/work/x86_64-linux/binutils-na
tive/2.35-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0 Output:
Applying patch gas_as.h.patch
patching file gas/as.h
Hunk #1 FAILED at 486.
1 out of 1 hunk FAILED -- rejects in file gas/as.h
Patch gas_as.h.patch can be reverse-applied

There are two more just like it, for the cross and target versions. All it
is is a patch to add one external function definition, but it's already
there.

Is there a preferred way to fix this with a bbappend? Perhaps replacing the
patch file with an empty one?

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com

Join yocto@lists.yoctoproject.org to automatically receive all group messages.