Re: Architecture did not match #yocto


Ross Burton
 

On Fri, 20 Nov 2020 at 17:04, <yuvaraj.velumani@denso-ten.com> wrote:
I am getting error while building google chromium depot-tools. My intentions is to build meta-flutter which depends on depot-tools.

ERROR: depot-tools-git-r0 do_package_qa: QA Issue: Architecture did not match (x86-64, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux64
Architecture did not match (x86, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux32 [arch]
The recipe for depot-tools is broken and is building native code when
a target depot-tools should be x86-64.

Whilst that is a valid issue in the recipe, did you mean to build
depot-tools-native instead?

Ross

Join yocto@lists.yoctoproject.org to automatically receive all group messages.