Re: Qtwebengine recipe in yocto zeus (latest version) #yocto #zeus #qt

Khem Raj

On 11/12/20 8:29 AM, anthony.marchand@... wrote:
I hope you're going well in this period.
I'm working with yocto (zeus version) with a soc i.MX6 and kernel 4.19. Actually, I meet a weird issue about the recipe "qtwebengine" in all of my projects that are using zeus version.
The compilation was working fine until there, but since approximatively two weeks, with no particular reason, whatever the project I want to compile, I'm unable to compile qtwebengine and making a rootfs image with it inside.
So I have tested:
1) bitbake qtwebengine
2) bitbake myimage
PS: myimage contain the recipe qtwebengine.
But whatever the bitbake commands 1 or 2, Bitbake shows me the same error I don't understand and this error follows:
| In file included from /usr/include/bits/errno.h:26:0,
|                  from /usr/include/errno.h:28,
|                  from /usr/include/c++/7/cerrno:42,
|                  from /usr/include/c++/7/ext/string_conversions.h:44,
|                  from /usr/include/c++/7/bits/basic_string.h:6361,
|                  from /usr/include/c++/7/string:52,
|                  from /usr/include/c++/7/stdexcept:39,
|                  from /usr/include/c++/7/array:39,
|                  from /usr/include/c++/7/tuple:39,
|                  from /usr/include/c++/7/bits/unique_ptr.h:37,
|                  from /usr/include/c++/7/memory:80,
|                  from ../../../../git/src/3rdparty/chromium/v8/src/torque/cfg.h:9,
|                  from ./../../../../git/src/3rdparty/chromium/v8/src/torque/,
|                  from v8_snapshot/gen/v8/
| /usr/include/linux/errno.h:1:10: fatal error: asm/errno.h: No such file or directory
|  #include <asm/errno.h>
|           ^~~~~~~~~~~~~
| compilation terminated.
| Makefile.gn_run:340: recipe for target 'run_ninja' failed
| make[3]: *** [run_ninja] Error 1
| make[3]: Leaving directory '/home/yocto/Dev/build_zeus/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.13.0+gitAUTOINC+5d4bac57a0_8a28c0bb19-r0/build/src/core'
| Makefile:82: recipe for target 'sub-gn_run-pro-make_first' failed
| make[2]: *** [sub-gn_run-pro-make_first] Error 2
| make[2]: Leaving directory '/home/yocto/Dev/build_zeus/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.13.0+gitAUTOINC+5d4bac57a0_8a28c0bb19-r0/build/src/core'
| Makefile:76: recipe for target 'sub-core-make_first' failed
| make[1]: *** [sub-core-make_first] Error 2
| make[1]: Leaving directory '/home/yocto/Dev/build_zeus/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.13.0+gitAUTOINC+5d4bac57a0_8a28c0bb19-r0/build/src'
| Makefile:48: recipe for target 'sub-src-make_first' failed
| make: *** [sub-src-make_first] Error 2
| WARNING: exit code 1 from a shell command.
ERROR: Task (/home/yocto/Dev/build_zeus/../meta-qt5/recipes-qt/qt5/ failed with exit code '1'
I don't understand why bitbake don't find '<asm/errno.h>', because it is present in the kernel 4.19 and in my host system ubuntu 18. Furthermore, I don't understand the problem with run_ninja.
I try to change my PC for compilation, but I have got the same error. The PC I use to compile with bitbake got 20 cores intel xeon and 32GB of ram. I think the problem is not from here. :-)
Does someone already meet this problem?
Does someone know where could be the problem?
it seems to be failing to find files on build host install and there were similar issues seen on chromium browswer long time ago which has been addressed in meta-browser. you might disable building torque perhaps to workaround it.

Thanks for all and best reguards: Anthony.

Join to automatically receive all group messages.