Re: proper recipe for building for beagle xM? meta-ti?

Denys Dmytriyenko

On Sun, Mar 04, 2012 at 12:45:01PM -0700, Gary Thomas wrote:
On 2012-03-04 12:27, Denys Dmytriyenko wrote:
On Sun, Mar 04, 2012 at 01:14:17PM -0500, Robert P. J. Day wrote:
On Sun, 4 Mar 2012, Gary Thomas wrote:

On 2012-03-04 05:19, Robert P. J. Day wrote:

not sure if you're suggesting i should now be able to build
for, say, beagleboard with the meta-ti layer, but i cloned meta-ti
into my yocto tree, added that layer to bblayers.conf, and tried

$ bitbake core-image-minimal

and got what i believe gary was referring to above:

$ bitbake core-image-minimal
Pseudo is not present but is required, building this first before the main
ERROR: ParseError at
Could not inherit file classes/systemd.bbclass
ERROR: Command execution failed: Exited with 1

or am i misreading what you wrote?
Oops, that's one more workaround I forgot to mention. This file
is in OE-core, but not in poky. I made a local copy in my distro
layer, but there must be a better way to handle it.
um ... AFAICT, that .bbclass file is in meta-oe, not oe-core. and
since i have meta-openembedded checked out, i simply copied the whole
thing into my yocto tree, then tweaked my bblayers.conf file to look

/home/rpjday/yocto/git/meta \
/home/rpjday/yocto/git/meta-yocto \
/home/rpjday/yocto/git/meta-ti \
/home/rpjday/yocto/git/meta-openembedded/meta-oe \
Either way, meta-oe is still required for meta-ti due to toolchain issues...
Can you explain what the toolchain problems are and why the versions in
oe-core don't work for meta-ti?
One of the issues:

I haven't tried if either 3.0 or a pending 3.1 update for Panda (from
omapzoom/ti-ubuntu), resolve this gcc-4.6 build issue. But either way I
believe there was something else with one of our components not building with
gcc-4.6 - SGX or multimedia, don't remember exactly.


Join { to automatically receive all group messages.