Re: python3-psycopg2cffi DEPENDS error cffi


Quentin Schulz
 

Hi Talel,

On Tue, Nov 10, 2020 at 05:23:09AM -0800, Bel Hadj Salem Talel wrote:
HI All,
I created a recipe with pipoe for python3-psycopg2cffi when compiling this error occured:


ERROR: Do not try to fetch `cffi>=1.0' for building. Please add its native
recipe to DEPENDS.
I created a recipe for python3-cffi and I made it native with BBCLASSEXTEND = "native" and it depends also on python3-pycparser which is already native and exist.
Then I added DEPENDS = "python3-cffi" to python3-psycopg2cffi recipe but failed with same error, I tried to rename the python3-cffi to just cffi but same error.
If the native version of python3-cffi is needed, add
DEPENDS = "python3-cffi-native".

Quentin

Join yocto@lists.yoctoproject.org to automatically receive all group messages.