python3-psycopg2cffi DEPENDS error cffi


Bel Hadj Salem Talel
 

HI All,
I created a recipe with pipoe for python3-psycopg2cffi when compiling this error occured:
ERROR: Do not try to fetch `cffi>=1.0' for building. Please add its native recipe to DEPENDS.
I created a recipe for python3-cffi and I made it native with BBCLASSEXTEND = "native" and it depends also on python3-pycparser which is already native and exist.
Then I added DEPENDS = "python3-cffi" to python3-psycopg2cffi recipe but failed with same error, I tried to rename the python3-cffi to just cffi but same error.

What I'm missing ?
Thanks ,Talel

Join yocto@lists.yoctoproject.org to automatically receive all group messages.