Re: proper recipe for building for beagle xM? meta-ti?

Robert P. J. Day

On Sun, 4 Mar 2012, Denys Dmytriyenko wrote:

On Sun, Mar 04, 2012 at 01:14:17PM -0500, Robert P. J. Day wrote:
On Sun, 4 Mar 2012, Gary Thomas wrote:

On 2012-03-04 05:19, Robert P. J. Day wrote:

not sure if you're suggesting i should now be able to build
for, say, beagleboard with the meta-ti layer, but i cloned meta-ti
into my yocto tree, added that layer to bblayers.conf, and tried

$ bitbake core-image-minimal

and got what i believe gary was referring to above:

$ bitbake core-image-minimal
Pseudo is not present but is required, building this first before the main
ERROR: ParseError at
Could not inherit file classes/systemd.bbclass
ERROR: Command execution failed: Exited with 1

or am i misreading what you wrote?
Oops, that's one more workaround I forgot to mention. This file
is in OE-core, but not in poky. I made a local copy in my distro
layer, but there must be a better way to handle it.
um ... AFAICT, that .bbclass file is in meta-oe, not oe-core. and
since i have meta-openembedded checked out, i simply copied the whole
thing into my yocto tree, then tweaked my bblayers.conf file to look

/home/rpjday/yocto/git/meta \
/home/rpjday/yocto/git/meta-yocto \
/home/rpjday/yocto/git/meta-ti \
/home/rpjday/yocto/git/meta-openembedded/meta-oe \
Either way, meta-oe is still required for meta-ti due to toolchain issues...
i *know* what i'm about to point out is an OE issue and i already
quietly emailed koen, but when i tried the above (actually reordered
my BBLAYERS entries first), i got a udev fetch error since it was
trying to fetch udev-173, and there is simply no such version at the
specified fetch location, so i added:


to my local.conf and it's building (currently 2222 of 2429). so
someone in the OE community is welcome to address the issue that there
is no udev-173 tarball here:

my bitbake should either finish or fail within 15 minutes.


Join { to automatically receive all group messages.