Re: poky-dunfell-23.0.2: WARNING: Your host glibc verson (2.32) is newer than that in uninative (2.31). Disabling uninative so that sstate is not corrupted.


Martin Jansa
 

I was able to reproduce this in one of my build setups and confirm that backporting this commit helps (and haven't found any other issues while building our images).

I've sent the backport request now.

On Mon, Sep 28, 2020 at 1:46 PM Richard Purdie <richard.purdie@...> wrote:
On Mon, 2020-09-28 at 10:34 +0200, Robert wrote:
> I tried the latest uninative from the same link, it will remove the
> warning but it doesn't solve the problem.
> If something else is wrong/different I would very much like a
> suggestion where to start looking for this difference.
> Finding something that isn't there is not easy :-\

You could try backporting:

http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=94b1d77472ad335f26ca4ea6ec8c5b399368c06e

Cheers,

Richard




Join yocto@lists.yoctoproject.org to automatically receive all group messages.