sd-bus.h not found when compiling #yocto

Bel Hadj Salem Talel <bhstalel@...>

Hi All,
I'm trying to create a recipe for wirepas_gateway , it is a python project, but it uses systemd dbus , and there is a .c file that includes  #include <systemd/sd-bus.h>
I tried to add "systemd" and "libsystemd" to RDPENDS, but same error keeps showing :
dbus_c.c:9:10: fatal error: systemd/sd-bus.h: No such file or directory|     9 | #include <systemd/sd-bus.h>
Here is my recipe:
SUMMARY = "Wirepas gateway transport service that connects the local dbus to a remote MQTT broker."
LICENSE = "Apache"
LIC_FILES_CHKSUM = "file://LICENSE;md5=cb6bb17b0d0cca188339074207e9f4d8"
SRC_URI = "file:///home/talel/Desktop/wirepas_gateway-${PV}/"
inherit setuptools3
RDEPENDS_${PN} += "libsystemd python3-pyyaml python3-grpcio python3-paho-mqtt python3-pydbus python3-wirepas_messaging"
RDEPENDS_${PN} += "python3-core python3-datetime python3-io python3-json python3-logging python3-netclient python3-paho-mqtt python3-pygobject python3-pyyaml python3-threading"

How can I solve the issue ?

Thanks, Talel

Join { to automatically receive all group messages.