useless-rpaths : How to solve it/Know if it should be solved ?

Vitor Crestani Goergen <crestanivitor@...>


I have been dealing with Yocto for about a month, so I am still a beginner.

I am usign a NXP Sabresd board with an iMX6 processor. I have the recipes from oe, bsp, freescale etc downloaded from the NXP website, although I replaced the kernel with the EVL core project kernel. I did this in a workspace using devtool.

I was able to bitbake and build this new kernel without a problem. After that, I set on to install some libraries, specifically libevl, which is the library from the EVL project. This source code comes with several makefiles. I don't understand most of the codes in these makefiles but I am currently working on that. 

I created a new layer and a recipe for this library. Initially I had an error of "files shipped but not installed" but that was fixed by adding some more information to FILES_${PN}. Now, I am stuck with the following error message when trying to build:

Error: QA issue: libevl: /work/{machine}/libevl/0.1-r0/packages-split/libevl/usr/lib/ contains probably redundant RPATH /usr/lib 

I am aware that a "solution" exists using INSANE_SKIP. I did that and everything worked. However, I would not like to put more things than I should just to take up space on the board.

What I tried so far was to add somefiles to FILES_${PN}-dev, telling Make to ignore RPATH (Using the variable CMAKE_IGNORE_RPATH) but none of these worked.

I've also seen in some discussions that maybe this should probably stay as it is. How can I determine if this is normal behaviour and I should just use INSANE_SKIP?

Thanks in advance,


Join { to automatically receive all group messages.