Re: simplest recipe for running yocto qemu images? [SOLVED]


Robert P. J. Day
 

On Fri, 2 Mar 2012, Paul Eggleton wrote:

On Friday 02 March 2012 07:16:08 Robert P. J. Day wrote:
i gathered that. but is it unreasonable to suggest that this is
something that *should* be easy to do? if new users simply want to
see what a yocto-generated image looks like under qemu, shouldn't
there be a way to let them do that without going through an entire
build?
I see what you're saying, but the problem with this is the qemu
version we build is not the same as qemu that might be installed on
the host machine. We apply quite a number of patches to qemu in
order to support features we need (such as GL); if you allow
beginners to easily use something else then it just makes support
harder because certain things that normally work in the current
setup will not work when the host tools are being used instead.
just for fun, i addressed the only thing that was stopping me, and
that was that runqemu was looking for a slightly different sysroots
directory name than the toolchain provided, so:

/opt/poky/1.1/sysroots$ sudo ln -s x86_64-pokysdk-linux/ x86_64-linux

and then ran:

$ TMPDIR=/opt/poky/1.1 runqemu qemuarm zImage-2.6.37-qemuarm-1.0.bin
core-image-minimal-qemuarm.ext3

and it worked. yes, i'm sure i'm abusing all sorts of things but, in
the end, once i dug through it, it seemed fairly easy to get it to
work.

rday

--

========================================================================
Robert P. J. Day Ottawa, Ontario, CANADA
http://crashcourse.ca

Twitter: http://twitter.com/rpjday
LinkedIn: http://ca.linkedin.com/in/rpjday
========================================================================

Join yocto@lists.yoctoproject.org to automatically receive all group messages.