[PATCH][autobuilder-helper][warrior 24/41] scripts/utils.py: Fix confusing naming of getcomparisonbranch() return value


Richard Purdie
 

From: Steve Sakoman <steve@sakoman.com>

This code was copy/pasted but in this case the variables should
be called "compare", not base.

Signed-off-by: Steve Sakoman <steve@sakoman.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
scripts/utils.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/scripts/utils.py b/scripts/utils.py
index 68652d9..5542fe2 100644
--- a/scripts/utils.py
+++ b/scripts/utils.py
@@ -358,9 +358,9 @@ def getcomparisonbranch(ourconfig, reponame, branchname):
if (reponame + ":" + branchname) in getconfig("BUILD_HISTORY_FORKPUSH", ourconfig):
base = getconfig("BUILD_HISTORY_FORKPUSH", ourconfig)[reponame + ":" + branchname]
if base:
- baserepo, basebranch = base.split(":")
- print("Comparing to %s\n" % (basebranch))
- return branchname, basebranch
+ comparerepo, comparebranch = base.split(":")
+ print("Comparing to %s\n" % (comparebranch))
+ return branchname, comparebranch
if (reponame + ":" + branchname) in getconfig("BUILD_HISTORY_DIRECTPUSH", ourconfig):
return branchname, None
return None, None
--
2.25.1

Join yocto@lists.yoctoproject.org to automatically receive all group messages.