#yocto #yocto


Pankaj Vinadrao Joshi
 

Hi,
i am building an image for RPI4 but while building core-image-sato i am getting the following error
pankaj@exaleap-Inspiron-3584:~/Oe-Raspberrypi4$ bitbake core-image-sato
Parsing recipes: 100% |######################################################################################################################################################################| Time: 0:01:56
Parsing of 2279 .bb files complete (0 cached, 2279 parsed). 3439 targets, 196 skipped, 0 masked, 0 errors.
ERROR: Nothing PROVIDES 'core-image-sato'
core-image-sato was skipped: 'hwcodecstools-debug' in IMAGE_FEATURES is not a valid image feature. Valid features: allow-empty-password allow-root-login bash-completion-pkgs dbg-pkgs debug-tweaks dev-pkgs doc doc-pkgs eclipse-debug empty-root-password hwcodecs nfs-client nfs-server package-management post-install-logging ptest-pkgs read-only-rootfs splash src-pkgs ssh-server-dropbear ssh-server-openssh stateless-rootfs staticdev-pkgs tools-debug tools-profile tools-sdk tools-testapps x11 x11-base x11-sato

later i have removed the hwcodecstools-debug feature from core-image-sato.bb then i got same above error for  ssh-server-dropbeartools-debug' likewise for all features (# IMAGE_FEATURES += "splash package-management x11-base x11-sato ssh-server-dropbear hwcodecs") from  core-image-sato.bb 

i am attaching detailed error message

ERROR: Nothing PROVIDES 'core-image-sato'
core-image-sato was skipped: 'hwcodecstools-debug' in IMAGE_FEATURES is not a valid image feature. Valid features: allow-empty-password allow-root-login bash-completion-pkgs dbg-pkgs debug-tweaks dev-pkgs doc doc-pkgs eclipse-debug empty-root-password hwcodecs nfs-client nfs-server package-management post-install-logging ptest-pkgs read-only-rootfs splash src-pkgs ssh-server-dropbear ssh-server-openssh stateless-rootfs staticdev-pkgs tools-debug tools-profile tools-sdk tools-testapps x11 x11-base x11-sato

This is error message when i removed  hwcodecstools-debug from 'core-image-sato
pankaj@exaleap-Inspiron-3584:~/Oe-Raspberrypi4$ bitbake core-image-sato
Loading cache: 100% |########################################################################################################################################################################| Time: 0:00:00
Loaded 3439 entries from dependency cache.
Parsing recipes: 100% |######################################################################################################################################################################| Time: 0:00:00
Parsing of 2279 .bb files complete (2274 cached, 5 parsed). 3439 targets, 196 skipped, 0 masked, 0 errors.
ERROR: Nothing PROVIDES 'core-image-sato'
core-image-sato was skipped: 'package-managementtools-debug' in IMAGE_FEATURES is not a valid image feature. Valid features: allow-empty-password allow-root-login bash-completion-pkgs dbg-pkgs debug-tweaks dev-pkgs doc doc-pkgs eclipse-debug empty-root-password hwcodecs nfs-client nfs-server package-management post-install-logging ptest-pkgs read-only-rootfs splash src-pkgs ssh-server-dropbear ssh-server-openssh stateless-rootfs staticdev-pkgs tools-debug tools-profile tools-sdk tools-testapps x11 x11-base x11-sato
 
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

This is error message when i removed  package-managementtools-debug' and  x11-base x11-sato ssh-server-dropbear from 'core-image-sato
pankaj@exaleap-Inspiron-3584:~/Oe-Raspberrypi4$ bitbake core-image-sato
Loading cache: 100% |########################################################################################################################################################################| Time: 0:00:00
Loaded 3439 entries from dependency cache.
Parsing recipes: 100% |######################################################################################################################################################################| Time: 0:00:00
Parsing of 2279 .bb files complete (2274 cached, 5 parsed). 3439 targets, 196 skipped, 0 mask 0 errors.
ERROR: Nothing PROVIDES 'core-image-sato'
core-image-sato was skipped: 'splashtools-debug' in IMAGE_FEATURES is not a valid image feature. Valid features: allow-empty-password allow-root-login bash-completion-pkgs dbg-pkgs debug-tweaks dev-pkgs doc doc-pkgs eclipse-debug empty-root-password hwcodecs nfs-client nfs-server package-management post-install-logging ptest-pkgs read-only-rootfs splash src-pkgs ssh-server-dropbear ssh-server-openssh stateless-rootfs staticdev-pkgs tools-debug tools-profile tools-sdk tools-testapps x11 x11-base x11-sato

1) Now i have removed all the features from that .bb file why i am getting these errors??

2) I have built the image without these configuration but after booting the image its asking for password for connecting from ssh thought i have not set any packages
i have included following features in local.conf file of build dir

EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
ENABLE_UART = "1"
#EXTRA_IMAGE_FEATURES ?= "allow-empty-password allow-root-login"
CORE_IMAGE_EXTRA_INSTALL += "git ruby bsdtar pseudo os-release lsb-release cmake"
DISTRO_FEATURES_append = "opengl python3-pip"
EXTRA_IMAGE_FEATURES_append += "src-pkgs package-management ssh-server-dropbear ssh-server-openssh stateless-rootfs "
PACKAGE_CLASSES = "package_deb"
IMAGE_INSTALL_append = " glibc-utils localedef unicode-ucd "
IMAGE_FEATURES_append = "tools-debug tools-sdk dev-pkgs"
CORE_IMAGE_EXTRA_INSTALL += " kernel-modules bash e2fsprogs mtools parted dosfstools mtd-utils-ubifs openssh"
IMAGE_INSTALL_append += " dhcp-client dhcp-server python3-pip "
DISTRO ?= "Exaleap-arm-linux"
 
can someone help me to ressolve this issue???

Join yocto@lists.yoctoproject.org to automatically receive all group messages.