Re: [layerindexweb][PATCH 0/7] Django 2.2 Upgrade


Paul Eggleton
 

Hi Amber

Thanks for doing this! I've just merged the patches this morning.

Next we need to figure out how to do the upgrade on the live site - which is a
little tricky given the current state of the RRS (where the upgrade requires
some manual data mangling on my part). Hopefully I can get this done some time
next week.

Cheers
Paul

On Friday, 26 June 2020 10:57:32 NZST Amber Elliot wrote:
These patches upgrade the layerindex to Django 2.2.

Amber Elliot (5):
README: Correcting mailing list.
Updating models and imports for Django 2.2 upgrade.
settings.py: Replacing MIDDLEWARE_CLASSES with MIDDLEWARE for Django
2.2 upgrade.
Replacing is_authenticated() with is_authenticated for Django upgrade.
requirements.txt: Updating Django requirement to the 2.2 LTS release.

Tim Orling (2):
Dockerfile: debian 10 "buster" and drop python2
docker/settings.py: MIDDLEWARE

Dockerfile | 13 ++--
README | 2 +-
docker/settings.py | 2 +-
layerindex/auth_views.py | 4 +-
layerindex/forms.py | 2 +-
layerindex/middleware.py | 2 +-
layerindex/migrations/0001_initial.py | 36 +++++------
layerindex/migrations/0002_distro.py | 2 +-
layerindex/migrations/0005_layerupdate.py | 4 +-
.../migrations/0010_add_dependencies.py | 2 +-
layerindex/migrations/0011_source.py | 2 +-
layerindex/migrations/0013_patch.py | 2 +-
.../0023_layerupdate_layer_branch_finalise.py | 4 +-
layerindex/models.py | 61 +++++++++----------
layerindex/urls.py | 2 +-
layerindex/urls_branch.py | 2 +-
layerindex/views.py | 32 +++++-----
requirements.txt | 2 +-
settings.py | 2 +-
urls.py | 4 +-
20 files changed, 89 insertions(+), 93 deletions(-)

Join yocto@lists.yoctoproject.org to automatically receive all group messages.