Re: uclibc elfutils

John Toomey <john.toomey@...>

On 27/02/2012 17:07, Khem Raj wrote:
On Mon, Feb 27, 2012 at 8:35 AM, John Toomey
<john.toomey@...> wrote:
Hello all,

I'm having some difficulty building elfutils (required by gdb) and I think
its relating to the fact that im using uclibc.
Yes elfutils has some glibc kinship unfortunately which is hard to untangle.
However gdb does not need elfutils in fact. please cherry-pick
following commit from oe-core master

commit 8330205eeb605354c139605618255940e3b312d4
Author: Khem Raj <raj.khem@...>
Date:   Fri Jan 20 17:07:42 2012 -0800

    gdb-common: Drop elfutils from DEPENDS

    Signed-off-by: Khem Raj <raj.khem@...>

NOTE: package elfutils-0.148-r5: task do_compile: Started
ERROR: Function failed: do_compile (see
for further information)
ERROR: Logfile of failure stored in:
Log data follows:
| DEBUG: SITE files ['endian-little', 'bit-32', 'ix86-common',
'common-linux', 'common-uclibc', 'i586-linux-uclibc', 'common']
| NOTE: make -j 24 -C libelf
| make: Entering directory
| elf_error.c:56:21: fatal error: libintl.h: No such file or directory
| compilation terminated.
| make: *** [elf_error.o] Error 1
| make: *** Waiting for unfinished jobs....
| make: Leaving directory
| ERROR: oe_runmake failed
NOTE: package elfutils-0.148-r5: task do_compile: Failed
ERROR: Task 218
([path]/poky/meta/recipes-devtools/elfutils/, do_compile)
failed with exit code '1'

The build works if I switch to eglibc. Can anyone help me figure out what
might cause this?


yocto mailing list

Hi Raj

Thank you for your reply - this seems to have resolved my issue.

Can you let me know if there is a correct way to build gdbserver into my target? I have tried a few things and none of them seem to work. THIS page suggests that there should be a gdbserver package but it doesn seem to exist when I try to include it. Including 'gdb' on its own doesnt seem to put gdbserver on the target. Also - i have tried EXTRA_IMAGE_FEATURES = "tools-debug" in local.conf but that breaks everything as it depends on X11 which I am not using.


Join to automatically receive all group messages.