Generating a genericx86_64 - bad hddimg #yocto


fnx_qt
 

Hello,

I'm trying to generate a simple genericx86_64 with Yocto 2.7 Warrior. Problem is that my hddimg is completely messed up upon generation.
I have not made any particular configuration apart from adding layers and modiying the local.conf file. Here is the content of the hddimg file:


% fdisk -l core-image-minimal-genericx86-64.hddimg images/genericx86-64 wagner
Disk core-image-minimal-genericx86-64.hddimg: 535.4 MiB, 561386496 bytes, 1096458 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x20ac7dda

Device Boot Start End Sectors Size Id Type
core-image-minimal-genericx86-64.hddimg1 3224498923 3657370039 432871117 206.4G 7 HPFS/NTFS/exFAT
core-image-minimal-genericx86-64.hddimg2 3272020941 5225480974 1953460034 931.5G 16 Hidden FAT16
core-image-minimal-genericx86-64.hddimg3 0 0 0 0B 6f unknown
core-image-minimal-genericx86-64.hddimg4 50200576 974536369 924335794 440.8G 0 Empty


Here is the bblayers.conf file:

% cat bblayers.conf build/conf wagner
# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
POKY_BBLAYERS_CONF_VERSION = "2"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
${TOPDIR}/../sources/poky/meta \
${TOPDIR}/../sources/poky/meta-poky \
${TOPDIR}/../sources/poky/meta-yocto-bsp \
${TOPDIR}/../sources/meta-openembedded/meta-oe \
${TOPDIR}/../sources/meta-openembedded/meta-python \
${TOPDIR}/../sources/meta-openembedded/meta-networking \
${TOPDIR}/../sources/meta-openembedded/meta-filesystems \
${TOPDIR}/../sources/meta-intel \
${TOPDIR}/../sources/meta-virtualization \
"


And here is the local.conf file (only the uncommented lines):

MACHINE ??= "genericx86-64"
DL_DIR ?= "/home/username/workspace/downloads"
SSTATE_DIR ?= "/home/username/workspace/sstate-cache"
DISTRO ?= "poky"
PACKAGE_CLASSES ?= "package_rpm"
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"
BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
CONF_VERSION = "1"

# Include SystemD and SystemCTL
DISTRO_FEATURES_append = " systemd virtualization"
VIRTUAL-RUNTIME_init_manager = "systemd"
VIRTUAL-RUNTIME_initscripts = "systemd-compat-units"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"

# Added Docker container to the image
IMAGE_INSTALL_append = " docker python3-docker-compose"
 



Do anyone have an idea of what the problem is ?

Join yocto@lists.yoctoproject.org to automatically receive all group messages.