#yocto #raspberrypi #linux . Failure to build xen-image-minimal. Yocto bitbake failed @99% while building xen-minimal-image. #yocto #raspberrypi #linux


Siddhartha V
 

Hello,

I am building the xen minimal image using yocto warrior ("bitbake xen-image-minimal") by giving the target machine as "raspberrypi4". It reached 99% but at last I got below error and the whole process terminated with error.

ERROR: xen-image-minimal-1.0-r0 do_rootfs: Could not invoke dnf. Command '/home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/recipe-sysroot-native/usr/bin/dnf -v --rpmverbosity=info -y -c /home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/rootfs/etc/dnf/dnf.conf --setopt=reposdir=/home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/rootfs/etc/yum.repos.d --installroot=/home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/rootfs --setopt=logdir=/home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/temp --repofrompath=oe-repo,/home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/oe-rootfs-repo --nogpgcheck install kernel-module-xen-blkback kernel-module-xen-gntalloc kernel-module-xen-gntdev kernel-module-xen-netback kernel-module-xen-wdt packagegroup-core-boot packagegroup-core-ssh-dropbear packagegroup-core-ssh-openssh qemu run-postinsts xen-base locale-base-en-us locale-base-en-gb' returned 1:

DNF version: 4.1.0

cachedir: /home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/rootfs/var/cache/dnf

Added oe-repo repo from /home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/oe-rootfs-repo

repo: using cache for: oe-repo

not found other for: 

not found modules for: 

not found deltainfo for: 

not found updateinfo for: 

oe-repo: using metadata from Wed 27 May 2020 06:15:39 AM UTC.

Last metadata expiration check: 0:00:01 ago on Wed 27 May 2020 06:15:45 AM UTC.

No module defaults found

No match for argument: kernel-module-xen-blkback

No match for argument: kernel-module-xen-gntalloc

No match for argument: kernel-module-xen-gntdev

No match for argument: kernel-module-xen-netback

No match for argument: kernel-module-xen-wdt

Error: Unable to find a match

 

ERROR: xen-image-minimal-1.0-r0 do_rootfs: 

ERROR: xen-image-minimal-1.0-r0 do_rootfs: Function failed: do_rootfs

ERROR: Logfile of failure stored in: /home/siddhu/Documents/yocto/build/tmp/work/raspberrypi4-poky-linux-gnueabi/xen-image-minimal/1.0-r0/temp/log.do_rootfs.14256

ERROR: Task (/home/siddhu/Documents/yocto/sources/meta-virtualization/recipes-extended/images/xen-image-minimal.bb:do_rootfs) failed with exit code '1'

NOTE: Tasks Summary: Attempted 2605 tasks of which 2152 didn't need to be rerun and 1 failed.

Summary: 1 task failed:

  /home/siddhu/Documents/yocto/sources/meta-virtualization/recipes-extended/images/xen-image-minimal.bb:do_rootfs

Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

May I know what mistake I am doing here please. I have attached screenshot also.


My bblayer.conf file is as below:

# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
POKY_BBLAYERS_CONF_VERSION = "2"
BBPATH = "${TOPDIR}"

BBFILES ?= ""
BBLAYERS ?= " \

  /home/siddhu/Documents/yocto/sources/poky/meta \
  /home/siddhu/Documents/yocto/sources/poky/meta-poky \
  /home/siddhu/Documents/yocto/sources/poky/meta-yocto-bsp \
  /home/siddhu/Documents/yocto/sources/meta-openembedded/meta-oe \
  /home/siddhu/Documents/yocto/sources/meta-openembedded/meta-multimedia \
  /home/siddhu/Documents/yocto/sources/meta-openembedded/meta-python \
  /home/siddhu/Documents/yocto/sources/meta-openembedded/meta-networking \
  /home/siddhu/Documents/yocto/sources/meta-openembedded/meta-filesystems \
  /home/siddhu/Documents/yocto/sources/meta-cloud-services \
  /home/siddhu/Documents/yocto/sources/meta-selinux \
  /home/siddhu/Documents/yocto/sources/meta-virtualization\
  /home/siddhu/Documents/yocto/sources/meta-raspberrypi \
  "

My local.conf file I have added the below details:

MACHINE ??= "raspberrypi4"
DISTRO_FEATURES += "virtualization xen"
PACKAGE_CLASSES ?= "package_rpm"
CONF_VERSION = "1"
IMAGE_FEATURES += "ssh-server-dropbear"


I have tried the same for "cubieboard2" also even there I faced the same issue.Eagerly waiting for the response.

Regards,
Siddhartha V

Join yocto@lists.yoctoproject.org to automatically receive all group messages.