Re: Regarding gnutls package in meta-gplv2 layer


Quentin Schulz
 

Hi Prashanth,

On Tue, May 05, 2020 at 08:22:07PM +0530, Prashanth wrote:
Hi Team,
I am trying to avoid GPLv3 package of gnutls from default Thud release.

So I was checking the gnutls package from meta-gplv2 layer:
http://git.yoctoproject.org/cgit/cgit.cgi/meta-gplv2/tree/recipes-support/gnutls/gnutls.inc?h=thud


But here as well I see that, this package is with GPLv3 license. Can you
please let me know, if I am missing anything here. If not, can you please
suggest if I have any alternate for GPLv2 version gnutls package.
It depends exactly which package you're talking about.

The superset of all licenses of all packages created by the gnutls
recipe is GPLv3+ & LGPLv2.1+. This is also the default if the license is
not explicited for a package.

gnutls package (not recipe, package) is licensed under LGPLv2.1+. Same
for gnutls-xx package.

gnutls-openssl and gnutls-bin are licensed under GPLv3+.

All other packages are under GPLv3+ & LGPLv2.1+.

Hope that helps.

Quentin

Join yocto@lists.yoctoproject.org to automatically receive all group messages.