Re: yocto on tinkerbaord using meta-rockchip

Sergey Bostandzhyan

Hi everyone,

On Mon, Mar 23, 2020 at 01:59:11PM -0400, Trevor Woerner wrote:
Testing a different image was a good idea, and the fact it didn't work
either suggests it might possibly be hardware related. To me this
suggests, perhaps, a power supply issue (i.e. the fact it boots up
partway then stops). Can you try with other sources of power?
this is indeed a good suggestion, I ran into such an issue myself, actually
had it with Armbian and was pointed here by the Armbian devs:

Apparently even picking a different USB cable can make a difference.

What I observed was that LEDs went off at some point during kernel
startup and the board went dead. After being pointed to the above link I
tried a much stronger USB power suppy (from an Acer netbook) and then
it suddenly worked without any modifications to the software.

Also, although the Tinkerboard has the same pin layout as the
Raspberry Pi, unlike the Raspberry Pi the Rockchip people like to use
UART2 for the console rather than UART1. Is your console cable
connected to UART2 (pins 32 and 33)?
I have a tinker-board-s, I am using it with meta-rockhip and I can confirm that
it works for me (also using UART2 on the pins described by Trevor), so the
layer as such should work...

Kind regards,

Join { to automatically receive all group messages.