Re: yocto on tinkerbaord using meta-rockchip


Karthik Poduval
 

Hi Trevor,

Thanks for getting back, I tried with tinker-board-s machine type but same result. I also tried flashing Asus Debian image on sdcard but that too didn't work (no console logs with this image). I am suspecting it's a hardware issue at this point. Any other suggestions or insights would be appreciated.

On Thu, Mar 19, 2020, 6:58 PM Trevor Woerner <twoerner@...> wrote:
Hi Karthik,

On Thu, Mar 19, 2020 at 9:36 PM karthik poduval
<karthik.poduval@...> wrote:
> Thank you for you work on meta-rockchip layer. You were listed as the
> maintainer for meta-rockchip so I though I will send you a mail with
> an issue I was facing.
>
> I was trying to flash an image on a Asus tinker board using
> meta-rockchip. Here are the steps I followed.
>
> git clone git://git.yoctoproject.org/poky
> git clone  git://git.yoctoproject.org/meta-rockchip
> source poky/oe-init-build-env
> bitbake-layers add-layer ../../meta-rockchip/
> MACHINE=tinker-board bitbake core-image-minimal
>
> #flahsed it using the following command to sdcard (my sdcard was dev/sde)
> sudo dd if=tmp/deploy/images/tinker-board/core-image-minimal-tinker-board.wic
> of=/dev/sde
>
> after inserting sdcard and booting up I can see on the serial console
> it attempts to boot, crosses bootloader and proceeds to linux boot but
> then gets hing around dwmmc_rockchip loading.
>
> Attached the complete serial log. Your help is greatly appreciated.

According to the log, your board is a "tinker-board-s", please try
using that for your MACHINE instead of "tinker-board".

Thanks and best regards,
    Trevor

Join yocto@lists.yoctoproject.org to automatically receive all group messages.