Problems finding a Command when using a cmake recipe in eSDK #yocto #sdk

Armando Hernandez


I created an eSDK and I am installing it on a docker image I created.
Using the devtool I added/created a recipe for a simple HelloWorld application (such application is located in github, but I guess this is not relevant).
My recipe inherits from cmake.
My CMakeLists.txt file contains a "add_custom_command" block where I am specifying a COMMAND to be called.
When running devtool build <recipe-name> I get errors letting me know that the file (i.e. the command) is not found.
The command in question can be found my means of a soft link located under /usr/bin/ - I can run the command inside my docker container without issues.
Actually, if I build the application using cmake in my docker container it will build without any issues. It is only when I try to use devtool, that the problem arises.

I found this question and have already tried the solution there offered, but it has not solved my problem.
So basically I added to my recipe:

with no success.

I also added message() calls to my CMakeLists.txt trying to find out more about this issue, but those message() calls are ignored by devtool (they are not printed).
I double checked that running cmake by myself prints such message() calls.

I built my eSDK using yocto Thud v2.6.2.

Any hints on how to debug this cmake problem or does anybody know why is the desired command not found when running devtool build?

Thanks in advance!


Join to automatically receive all group messages.