Re: [RFC PATCH] python: remove Python 2 and all supporting classes


Adrian Bunk
 

On Tue, Jan 21, 2020 at 06:27:57PM +0100, Martin Jansa wrote:
There is nodejs upgrade to 12.x on oe-devel ML:
http://lists.openembedded.org/pipermail/openembedded-devel/2020-January/204363.html
so we won't be staying on 10.x, but if 12.x isn't enough to build without
meta-python2, then we might need 13.x :/.
13.x is a short-term stable that will become EOL this June.

12.x is LTS with 2 years of upstream security support left when
Yocto 3.1 releases.

From a security support point of view shipping Python 2 in meta-oe
for the Yocto 3.1 release might be better than upgrading Node.js

cu
Adrian

Join yocto@lists.yoctoproject.org to automatically receive all group messages.