Re: Root login not working with Warrior


Paul Eggleton
 

Hi Teemu

On Tuesday, 14 January 2020 4:37:29 AM NZDT Teemu K. wrote:
I have Yocto image that was originally made with Thud - version of
Yocto. It was working fine and I was able to login as root via serial
console.

Then I updated Yocto to Warrior and now for some reason when I try to
login as root via serial console it says 'login incorrect' when I
enter 'root' as a user and press enter. It doesn't even ask any
passwords before saying that. I tried enabling debug-tweaks and still
the same. Can't login as a root.

I have another user that I can login just fine and with sudo I can
also use root access. I just can't login as root.

I looked through /etc/passwd and /etc/shadow and they looked okay. Has
something changed in Warrior regarding this? I tried googling, but
didn't find anything.
Is there an /etc/securetty file and if so what does it contain?

Cheers
Paul

--

Paul Eggleton
Intel System Software Products

Join yocto@lists.yoctoproject.org to automatically receive all group messages.