Re: Root login not working with Warrior

Randy MacLeod

On 1/13/20 10:37 AM, Teemu K. wrote:
I have Yocto image that was originally made with Thud - version of
Yocto. It was working fine and I was able to login as root via serial
Then I updated Yocto to Warrior and now for some reason when I try to
login as root via serial console it says 'login incorrect' when I
enter 'root' as a user and press enter. It doesn't even ask any
passwords before saying that. I tried enabling debug-tweaks and still
the same. Can't login as a root.
I have another user that I can login just fine and with sudo I can
also use root access. I just can't login as root.
I looked through /etc/passwd and /etc/shadow and they looked okay. Has
something changed in Warrior regarding this? I tried googling, but
didn't find anything.
Hi Teemu,

I'm not sure what's wrong but you can always add strace to your image,
login as a user and run:
$ sudo strace -f -o /tmp/trace-[root|user].log -p <pidof login>
where the pid you specify is either the login process or agetty. I'd
have to try it to figure out what process to trace.

If you do that and then login as 1) root and then 2) as a user, you can
compare the strace logs and usually figure out what the difference is.
The logs will be verbose and do require some expertise to understand
but that should help. ltrace is also sometimes helpful.

Good luck,

-Teemu K.

# Randy MacLeod
# Wind River Linux

Join to automatically receive all group messages.