Re: Raspberry pi 4 recipe and layer issues.

Ed Vidal

Hi Josef,
Thanks for your help. 

My icestorm recipe still fails trying to include ftdi.h even with in the DEPENDS.
has libftdi.  The header file is found libftdi-dev rpm.  When I tried adding it to DEPENDS. I get nothing provides 

Making progress in the yosys recipe now getting to do_install where the error see below 
Unable to recognise the format of the input file `/home/vidal/wkg/yocto-zeus-3.0/rpi4-64/build/tmp/work/aarch64-poky-linux/yosys/0.1+gitAUTOINC+e275692e84-r0/image/usr/local/bin/yosys'
    Makefile:567: recipe for target 'install' failed

    getting error in do_compile
    bash: tclsh: command not found
    Have tried adding to DEPENDS one at time bash
    and tclsh.
    Have tried adding to inherit one at time bash
    and tclsh.
    In the Makefile chg line 110
    to ae6716b default
    ABCREV = ae6716b
    ABCREV = default
    [100%] Building yosys
      Build successful
    This is part of do_install
    [  5%] ABC: `` Building binary: abc-default
    [ 10%] Building yosys-abc
    mkdir -p /home/vidal/wkg/yocto-zeus-3.0/rpi4-64/build/tmp/work/aarch64-poky-linux/yosys/0.1+gitAUTOINC+e275692e84-r0/image/usr/local/bin
    cp yosys yosys-config yosys-abc yosys-filterlib yosys-smtbmc /home/vidal/wkg/yocto-zeus-3.0/rpi4-64/build/tmp/work/aarch64-poky-linux/yosys/0.1+gitAUTOINC+e275692e84-r0/image/usr/local/bin
    aarch64-poky-linux-strip -S /home/vidal/wkg/yocto-zeus-3.0/rpi4-64/build/tmp/work/aarch64-poky-linux/yosys/0.1+gitAUTOINC+e275692e84-r0/image/usr/local/bin/yosys
    aarch64-poky-linux-strip: Unable to recognise the format of the input file `/home/vidal/wkg/yocto-zeus-3.0/rpi4-64/build/tmp/work/aarch64-poky-linux/yosys/0.1+gitAUTOINC+e275692e84-r0/image/usr/local/bin/yosys'
    Makefile:567: recipe for target 'install' failed
    make: *** [install] Error 1
    +inherit pkgconfig
    -       oe_runmake install
    +       oe_runmake install 'DESTDIR=${D}'

Let me know if I can provide additional information.

Edward Vidal Jr. e-mail develone@... 915-595-1613

On Friday, December 13, 2019, 1:20:48 AM MST, Josef Holzmayr <holzmayr@...> wrote:

On Thu, Dec 12, 2019 at 10:20:03PM +0000, Ed Vidal wrote:

> Hi AllAny and all help is appreciated.  Thanks in advance.
> I want to install 6 software packages needed for FPGA Development.These are icestorm, arachne-pnr, yosys, nextpnr, verilator, and zipcpu.I have created 4 of the recipes (,,, and the recipetool & bitbake-layers, and I added these to a meta-yosys-tools layer.
> I can now execute "bitbake icestorm" which is a python and C++ Makefile project.The first time the recipe goes thru the python build and gets an error existing the shell.If I rerun "bitbake icestorm" I get 
> | iceprog.c:27:10: fatal error: ftdi.h: No such file or directory|    27 | #include <ftdi.h>|       |          ^~~~~~~~Which is the 2nd C++ program in the Makfile.On the rpi4-64 all that is needed are the following steps to build icestorm git clone cd icestorm  make real 33m4.774s user 32m39.073s sys 0m19.247s I first tried using the cross compiler with little sucess.  This is why I trying to generate the recipes to build using bitbake instead. These are the location of the header files, needed to be added to the cross compiler sdkwhich I installed for rpi4 using the following commands. "bitbake meta-toolchain" "bitbake core-image-sato -c populate_sdk_ext" "./"
>   /usr/include/libftdi1/ftdi.h/usr/include/pcap/usb.h
> As root make install which install to /usr/local/bin & /usr/local/share.Creates /usr/local/bin & /usr/local/sharels /usr/local/bin/ icebox_diff icebox_maps  icebram   iceprogicebox_asc2hlc icebox_explain icebox_stat  icemulti  icetimeicebox_chipdb icebox_hlc2asc icebox_vlog  icepack   iceunpackicebox_colbuf icebox_html  icepll
> ls /usr/local/share/icebox/chipdb-1k.txt chipdb-lm4k.txt   timings_lp1k.txt   timings_up5k.txtchipdb-384.txt chipdb-u4k.txt   timings_lp384.txtchipdb-5k.txt timings_hx1k.txt  timings_lp8k.txtchipdb-8k.txt timings_hx8k.txt  timings_u4k.txt
> When I executed "bitbake nextpnr", I noticed the boost was built first.  Since then I have added boost to rpi4-core-image-sato which added quite a bit to the image2420113408 without boost and 2839543808 with boost.

This sounds all very much like you just need to sort out your
dependencies. If something needs boost, there should be

DEPENDS = "boost"

in the recipe. If smething needs libftdi, there should be

DEPENDS = "libftdi"

and so on, and so on. Randomly adding things to the image does not solve
those issue, for a simple reason: It guarantees that the thing go into
the image. It does *not* guarantee that they are already around when
some random, other recipe is being built.

So, first and foremost - sort out your dependencies.

There is some introductory information here:


Josef Holzmayr
Software Developer Embedded Systems

Tel: +49 8444 9204-48
Fax: +49 8444 9204-50

R-S-I Elektrotechnik GmbH & Co. KG
Woelkestrasse 11
D-85301 Schweitenkirchen
Amtsgericht Ingolstadt – GmbH: HRB 191328 – KG: HRA 170393
Geschäftsführer: Dr.-Ing. Michael Sorg, Dipl.-Ing. Franz Sorg
Ust-IdNr: DE 128592548

Amtsgericht Ingolstadt - GmbH: HRB 191328 - KG: HRA 170363
Geschäftsführer: Dr.-Ing. Michael Sorg, Dipl.-Ing. Franz Sorg
USt-IdNr.: DE 128592548

Join to automatically receive all group messages.