Re: No Package Provides /bin/awk


Adrian Bunk
 

On Tue, Nov 12, 2019 at 04:08:48PM -0600, Wayne Li wrote:
Dear Yocto Developers,

I'm trying to to build a Yocto kernel for a T4240 RDB. When I run "bitbake
fsl-image-full" to build the entire linux image, I get an error that says
"Can't install kernel-devsrc-1.0-r0@t4240rdb_64b: no package provides
/bin/awk". Here's the entire error print that I see:

https://gist.github.com/WayneZhenLi/e35f65081092cf1f24df29ec369c701c

Anyway I'm confused about this error because /bin/awk does exist. Like if
I run "/bin/awk" in the console I see help info come up describing how to
use a program called "gawk". Why can't bitbake find /bin/awk then? Or am
I misunderstanding what this error is trying to say? I mean I'm assuming
it's just not able to find /bin/awk but maybe the error means something
else? Or maybe /bin/awk is actually relative to some path? Let me know
your thoughts.
/bin/awk is missing on your target image that will run on the T4240 RDB.

The smallest implementation is to enable CONFIG_AWK in your busybox config.

-Thanks!, Wayne Li
cu
Adrian

--

"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed

Join yocto@lists.yoctoproject.org to automatically receive all group messages.