Why does enabling initramfs pull eudev into my build?


Patrick Doyle <wpdster@...>
 

Did that get your attention? :-)

I am trying to understand why eudev gets pulled into my build, where
it wasn't part of it before. I recently added an initramfs to my
build by setting:

INITRAMFS_IMAGE_BUNDLE="1"

in my machine.conf file. I have a custom, very minimal initramfs.bb
recipe that doesn't do much more than:

NO_RECOMMENDATIONS_pn-initramfs = "1"
PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} validate-rootfs"
IMAGE_FEATURES = ""
export IMAGE_BASENAME = "${MLPREFIX}initramfs"
IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
inherit core-image

When I run:

$ bitbake base-image -g -u taskexp

I see that eudev.do_build lists "base-image.du_build" as a dependent
task and, for some reason, eudev.do_packagedata lists
"initramfs.do_roofs" as a dependent task.

When I remove INITRAMFS_IMAGE_BUNDLE from my machine.conf file, eudev
is no longer included in my image. (Although, oddly,
initramfs.do_build is listed as a dependent task of eudev.do_build
when I run taskexp on my initramfs recipe, but not when I run it on
the base-image recipe.)

Can anybody point me at (more) tools that can help me understand what
I did to my initramfs.bb recipe that caused eudev to be included in my
build?

Thanks

--wpd

Join yocto@lists.yoctoproject.org to automatically receive all group messages.