Re: List of Supported Python versions


Jaymin Dabhi
 

Hi Maciej,

Thanks for the link.
If I want to use different(updated) version of a particular function, e.g. Python, Is is possible?
As per link Jethro is supporting Python version 2.7.9. I want to integrate Python version 2.7.16 and Python3 3.7.
So, Do I need to use another branch which is supporting these versions or Is there any way to integrate these versions without changing current(Jethro) branch?

In my case, I have limitation. Can't change to any other branch.
I want to integrate Python3-Numpy, Python3-OpenCV, Python-Scipy and Python3-scipy modules in the build.
Python3-Scipy is dependent on Python3-Numpy and Python3-Numpy is dependent on OpenBLAS, ATLAS and few other libraries. While these libraries are dependent on FORTRAN (libgfortran) compiler. Now, in my current (Jethro) branch, when I am trying to build libgfortran, it requires GCC version >=5. And, facing so many errors while building GCC 5.2 in the Yocto build. While GCC 5.2.0 is already supported in the Jethro.

In simple,
How can I integrate Python3-Numpy, Python-Scipy, Python3-Scipy and Python3-OpenCV packages without changing the branch?
What is the simplest way to integrate above packages?

Please suggest.

Regards,
Jaymin

On 18-07-2019 12:24 PM, Maciej Pijanowski wrote:
The link to the search engine:
https://layers.openembedded.org/layerindex/branch/master/recipes/
On 18.07.2019 07:41, jaymin.dabhi@vivaldi.net wrote:
Hello Team,
Which Python, Python-OpenCV, Python-Numpy, Python-Scipy and OpenCV
(max)versions are supported in Yocto 2.0.3 (Jethro) distro version?
Can I get list of notes in which version of all supported modules have
been mentioned?
Please let me know.
Regards,
Jaymin
--
Maciej Pijanowski
Embedded Systems Engineer
https://3mdeb.com | @3mdeb_com
--
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto

Join yocto@lists.yoctoproject.org to automatically receive all group messages.