Re: 1.2_M2-Final build failures


Jim Abernathy
 

On 02/01/2012 11:41 AM, Paul Eggleton wrote:
On Wednesday 01 February 2012 11:28:22 jfabernathy wrote:
Using the tarballs for Poky and meta-intel for 1.2_M2-Final, I was
getting a lot of build failures below is what worked and what didn't.
Not sure if this is a bug or if I'm missing something. I extracted the
meta-intel tarball for 1.2_M2-Final in the poky directory created by
extracting the poky tarball for 1.2_M2.Final.
...
3. building n450 core-image-minimal fails with error: ERROR: Unable to
parse /home/jim/poky/meta/recipes-core/tasks/task-base.bb:00:20
Traceback (most recent call last):
File "/home/jim/poky/bitbake/lib/bb/parse/ast.py", line 379, in
multi_finalize(fn='/home/jim/poky/meta/recipes-core/tasks/task-base.bb
<http://task-base.bb>', d=<bb.data_smart.DataSmart object at
0x4a801d0>):

try:
> finalize(fn, d)

except bb.parse.SkipPackage as e:
File "/home/jim/poky/bitbake/lib/bb/parse/ast.py", line 323, in
finalize(fn='/home/jim/poky/meta/recipes-core/tasks/task-base.bb
<http://task-base.bb>', d=<bb.data_smart.DataSmart object at
0x4a801d0>, variant=None):
code.append("%s(d)" % funcname)

> bb.utils.simple_exec("\n".join(code), {"d": d})

bb.data.update_data(d)
File "/home/jim/poky/bitbake/lib/bb/utils.py", line 387, in

simple_exec(code='__anon_119__home_jim_poky_meta_classes_staging_bbclass(d)
\n__anon_485__home_jim_poky_meta_classes_base_bbclass(d)\n__anon_189__home_j
im_poky_meta_classes_package_bbclass(d)\n__anon_1034__home_jim_poky_meta_cla
sses_package_rpm_bbclass(d)\n__anon_20__home_jim_poky_meta_classes_debian_bb
class(d)\n__anon_55__home_jim_poky_meta_classes_sstate_bbclass(d)\n__anon_26
__home_jim_poky_meta_classes_task_bbclass(d)\n__anon_140__home_jim_poky_meta
_recipes_core_tasks_task_base_bb(d)', context={'d':<bb.data_smart.DataSmart
object at 0x4a801d0>}):
def simple_exec(code, context):
> exec(code, _context, context)

File "<string>", line 8, in<module>
File
"__anon_140__home_jim_poky_meta_recipes_core_tasks_task_base_bb",
line 8, in

__anon_140__home_jim_poky_meta_recipes_core_tasks_task_base_bb(d=<bb.data_s
mart.DataSmart object at 0x4a801d0>)
AttributeError: 'NoneType' object has no attribute 'split'

ERROR: Command execution failed: Exited with 1
Summary: There were 1 WARNING messages shown.

Summary: There were 1 ERROR messages shown, returning a non-zero
exit code.

4. building cedartrail core-image-minimal fails with error: ERROR:
Unable to parse conf/bitbake.conf: Could not include required file
conf/machine/include/ia32-base.inc
I think I know what's going on here. In previous editions it was enough to
have just the meta-intel sub-layer in your bblayers.conf (e.g. meta-crownbay)
- now you also need to add meta-intel itself to get certain common files. If
you do this then your errors will go away.

I did notice this the other day and I think we can improve things such that
you get a sensible error message in this situation rather than the above. I
will try to send out some patches next week.
okay that fixed it. To be clear:

BBFILES ?= ""
BBLAYERS ?= " \
/home/jim/poky-edison-6.1-M2/meta \
/home/jim/poky-edison-6.1-M2/meta-yocto \
/home/jim/poky-edison-6.1-M2/meta-intel \
/home/jim/poky-edison-6.1-M2/meta-intel/meta-cedartrail \
"

instead of

BBFILES ?= ""
BBLAYERS ?= " \
/home/jim/poky-edison-6.1-M2/meta \
/home/jim/poky-edison-6.1-M2/meta-yocto \
/home/jim/poky-edison-6.1-M2/meta-intel/meta-cedartrail \
"

Now if this is the way it remains, we have some docs to cleanup.

Jim A

Cheers,
Paul

Join yocto@lists.yoctoproject.org to automatically receive all group messages.