Re: ASSUME_PROVIDED, cmake-native and why cmake is subsequently not found?


Robert P. J. Day
 

On Thu, 25 Apr 2019, Richard Purdie wrote:

On Thu, 2019-04-25 at 08:05 -0400, Robert P. J. Day wrote:
/home/rpjday/oe/builds/zedboard/tmp/work/x86_64-linux/cmake-
native/3.12.2-r0/build/Bootstrap.cmk/cmake:
/home/rpjday/oe/builds/zedboard/tmp/sysroots-uninative/x86_64-
linux/usr/lib/libstdc++.so.6:
version `GLIBCXX_3.4.26' not found (required by
/home/rpjday/oe/builds/zedboard/tmp/work/x86_64-linux/cmake-
native/3.12.2-r0/build/Bootstrap.cmk/cmake)
---------------------------------------------
Error when bootstrapping CMake:
Problem while running initial CMake
---------------------------------------------
This probably means that your system c library is newer than the one
in uninative and things aren't working because of that. Either try:

http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=5f6156b32c9d17bdb06d67199373433b0e470cc7
that patch is already in thud branch of poky i'm using ...

or turning off uninative.
yes, that seems to have solved things for now:

INHERIT_remove = "uninative"

moving on to the next head-scratcher ...

rday

--

========================================================================
Robert P. J. Day Ottawa, Ontario, CANADA
http://crashcourse.ca

Twitter: http://twitter.com/rpjday
LinkedIn: http://ca.linkedin.com/in/rpjday
========================================================================

Join yocto@lists.yoctoproject.org to automatically receive all group messages.