Re: m4-mative: "Please port gnulib fseeko.c to your platform!"

Robert P. J. Day

On Mon, 8 Apr 2019, Robert P. J. Day wrote:

a few months ago, i ran into (and asked about) a failure building
m4-native that you can read here:

first, i will admit i'm not sure where the fault lies -- is it m4, or
gnulib, or glibc, and whose responsibility is it to fix what. i'll be
honest -- i don't understand what the bug is or who should be
resolving it.

i ask all this as i just had *exactly* the same error trying to
build agl-image-minimal with the AGL code base. what is the proper
solution to this? BTW, i'm trying this on fedora 30 branched, so this
is definitely not a supported build distro, but i'm still curious as
to what would be the proper fix.

finally, it occurs to me that, if building a native package like
"m4" fails, would it be a reasonable workaround to simply say


for the time being, to avoid having to build it until i know what the
proper fix is?
trying ASSUME_PROVIDED didn't work all that well, either ...

| autom4te: need GNU m4 1.4 or later: m4
| make[2]: *** [Makefile:641:] Error 1

that's just weird as my installed version of m4 is 1.4.18, precisely
the version AGL is trying to build. i'm confused.



Robert P. J. Day Ottawa, Ontario, CANADA


Join to automatically receive all group messages.