[SDK] including kernel devsrc to the SDK failes


Måns Zigher <mans.zigher@...>
 

Hi,

I am trying to add the kernel devsrc to the SDK but I am getting the following error

Problem: conflicting requests                                        
  - nothing provides /bin/awk needed by kernel-devsrc-1.0-r0.imx8mqevk

I have applied the following patch to try and fix this problem.


I have verified that it was applied and run kernel-devsrc works. The error is from do_populate_sdk and I am suspecting that the problem is related to me using rpm. I believe rpm might be to smart in this case detecting the dependency and resulting dnf from failing when running the task do_populate_sdk. Any suggestion on how to get forward on this error. I would like to run dnf manually to check any dependency of the kernel-devsrc rpm package but cannot figure out how.

BR
Måns Zigher

Join yocto@lists.yoctoproject.org to automatically receive all group messages.