Re: [poky][meta] already-stripped ignore if set for any other package then INSANE_SKIP_${PN}


Måns Zigher <mans.zigher@...>
 

Hi,

Sorry I see now that there is a typo. What I mean is that in the default package I am not suing INSANE_SKIP but for packag1 I need already-stripped

INSANE_SKIP_${PN}-package1 = " \
dev-so \
already-stripped \
"

But I continuously get the error that they are already-stripped. So is it supposed to work because I don't understand  the code in the package.bbclass since it looks like it is only checking for already-stripped in ${PN} and not ${PN}-package1?

BR
Måns Zigher



Den fre 12 okt. 2018 kl 16:30 skrev Burton, Ross <ross.burton@...>:

On Thu, 11 Oct 2018 at 18:14, Måns Zigher <mans.zigher@...> wrote:
> I have been struggling with a problem where I need to create a package in a recipe and set already-stripped for that package. The package in question is not the the default one so I am trying to set it by using
>
> INSANE_SKIP_${PN} += " \
> dev-so \
> already-stripped \
> "

You say no the default one, but PN is "the default" one, so that's
probably why that doesn't work.

Ross

Join yocto@lists.yoctoproject.org to automatically receive all group messages.