Re: Does Edison work with Beagleboard & linux-yocto-3.0 kernel?


Joshua Lock <josh@...>
 

On 11/01/12 06:41, Brian Hutchinson wrote:
Hi,

I followed the example in the "Yocto Project Development Manual" for
setting up a local kernel repo and it didn't go so well.

A month or two ago I checked out Edison and was able to build all the
images required for Beagleboard and it booted fine (using command line
... not hob. Tried hob but couldn't get it to work).

So then I checked out linux-yocto-3.0 kernel and setup a local kernel
git repo and went through the process of setting up poky-extras,
modifying bblayers.conf etc. to point to my local repo.

Any time I try to build core-image-minimal it looks like it always
wants to use the 2.6.37 recipe instead of finding my 3.0 repo. I've
tried everything I can think of and I must me missing something.
In meta-yocto/conf/distro/poky.conf there's a line which sets:

PREFERRED_VERSION_linux-yocto ?= "2.6.37+git%"

Which is then overridden for the qemu machines to:

PREFERRED_VERSION_linux-yocto_qemuppc ?= "3.0%"

If you add a similar line for beagleboard to a conf file, such as local.conf, it would look for a 3.0 kernel version and use your tree.

PREFERRED_VERSION_linux-yocto_beagleboard ?= "3.0%"

I know you've switched to master but I wanted to help you understand the system is doing what it is.

Cheers,
Joshua
--
Joshua Lock
Yocto Project "Johannes factotum"
Intel Open Source Technology Centre

Join {yocto@lists.yoctoproject.org to automatically receive all group messages.