Re: OpenCV with python3


Tim Orling
 

Ditto for Robert’s comment. Please look at the bitbake manual and understand what the syntax means [1].

Also,  “python-foo” means the python2 version. The default PACKAGECONFIG [2] for opencv builds for python3. You need “python3-opencv”.

Finally, I would encourage you to use CORE_IMAGE_EXTRA_INSTALL [3] rather than IMAGE_INSTALL in the local.conf context.


On Thu, Mar 15, 2018 at 5:57 AM Robert P. J. Day <rpjday@...> wrote:
On Thu, 15 Mar 2018, Peter Balazovic wrote:

> Hello all,
> I have python module of OpenCV for python 2.7 on my Yocto image adding via local.conf
>
> IMAGE_INSTALL_append += “ python-opencv”

  i know i've harped on this before, but can people please stop
combining the constructs "_append" and "+=" in the same expression?

rday--
_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto

Join yocto@lists.yoctoproject.org to automatically receive all group messages.