dev-pkgs not installed in Extensible SDK


Adrian Dudau
 

Adding dev-pkgs to SDKIMAGE_FEATURES I expected that the -dev packages
would be installed in the sysroot in the eSDK, but it seems that is
valid only for the standard SDK.

I have my own image that inherits core-image with various additions. In
the standard SDK, the debug folder under rpi_standard/sysroots/aarch64-
enea-linux/usr/src/debug shows like this:
acl          expat        less           libtirpc            make      
       rpcbind
atk          file         libaio         libtool             mingetty  
       rpm
attr         findutils    libarchive     libunistring        mpfr      
       rsync
babeltrace   fontconfig   libassuan      liburcu             ncurses   
       shadow
base-
passwd  freetype     libcap         libx11              nettle         
  shared-mime-info
bash         fuse         libcheck       libxau              nfs-
utils        slang
bc           gcc-
runtime  libcomps       libxcb              nspr             sqlite3
blktrace     gdbm         libdnf         libxcomposite       nss       
       strace
busybox      gdk-
pixbuf   libevent       libxcursor          openssh          systemd
bzip2        gettext      libffi         libxdamage          openssl   
       systemtap
cairo        glib-
2.0     libgcc         libxdmcp            pango            tcf-agent
ccache       glibc        libgpg-
error   libxext             patch            tcl
coreutils    gmp          libidn         libxfixes           pciutils  
       tcp-wrappers
curl         gnutls       libjpeg-
turbo  libxft              perl             trace-cmd
db           gpgme        libmpc         libxml2             pixman    
       util-linux
dbus         gtk+         libnfsidmap    libxml-parser-
perl  pkgconfig        xz
dhcp         harfbuzz     libnl          libxrandr           popt      
       zlib
diffstat     json-c       libpcre        libxrender          powertop
diffutils    kbd          libpng         lttng-tools         python3
e2fsprogs    kmod         librepo        lttng-ust           python3-
pygpgme
elfutils     latencytop   libsolv        m4                  readline


In the extensible SDK, I only have this under rpi/sysroots/aarch64-
enea-linux/usr/src/debug:
bash  bc  glibc  ncurses


I tried building both SDKs based on a vanilla core-image-minimal, and
the standard SDK has the sources installed as expected, but the ext SDK
has no debug folder containing sources. I tried

I tried looking into the populate_sdk* classes, but the code there is
very hard to understand at a first view. So I guess question is: Is
this intended by design or is it a bug? If intended, what is the
development worklfow for a user wanting to remote debug applications
using shared libraries?

Best regards,
--Adrian

Join yocto@lists.yoctoproject.org to automatically receive all group messages.